Reeder for MacにGrowl通知を追加

Posted by Yoshimasa Niwa on 12/05, 2010

数日前に素晴らしいGoogle Readerのクライアント、ReederのMac版が登場しました。 もともとReederはiPhone, iPad用のアプリで、最高のiPhone, iPadアプリのひとつでした。

現在Reeder for Macはベータ版としてリリースされています。とても良いアプリなのですが、何かが足らないのです。そう、Growlによる通知です。実は、昨年Tweetieで似たようなことをやっています。

そこでReeder for MacのプラグインをつくってGrowlによるデスクトップ通知を可能にしました。 未読の記事があるとすぐに通知されるようになります。これで読み逃しと未読地獄からは開放される(かも)しれませんね。 多分近い将来Reeder for Mac自体がデスクトップ通知を実装するとは思いますが、今なにも無いよりはいいかなと思い公開します。

ダウンロードとインストール

  1. まずは、Reeder for Macをインストール。 Reeder fro Macのダウンロード先はReeder開発者のツイートで見つかります。
  2. 未だSIMBLをインストールしていなかったら、このプラグインはSIMBLが必要ですので、 先にインストールしてください。
  3. このプラグインをダウンロードしてパッケージを展開してください。
  4. Reeder for Macを実行していたら終了して、(自分のホーム)/Library/Application Support/SIMBL/Pluginsにフォルダがなければ作成してください。 そして展開したGrowlReeder.bundlePluginsフォルダにコピーします。
  5. Reeder for Macを実行すると新着通知が有効になります :)

ご注意

もしGoogle Readerに未読記事が大量にある場合、このプラグインはReeder for Macの初回起動時に大量のGrowl通知を表示してしまいます。 そのような場合は、まず先にReeder for Macを起動してすべての記事を読み込ませてからこのプラグインをインストールしてください。

バージョン0.1.1で一度にたくさんの通知は表示されないようにしました。

変更履歴

ソースコード

ソースコードはgithubのレポジトリで公開しています。

ライセンス

GrowlReederはMIT Licenseで公開しています。

Share

Comments

  • Patrickさんのコメント 12/11, 2010
    Thank you for the nice plugin. Would it be possible to open the item in Reeder with a click on the growl message?
  • Yoshimasa Niwaさんのコメント 12/19, 2010
    Patrick: I guess yes, I'll try to implement your request on next version... I didn't check the code though.
  • Patrickさんのコメント 12/23, 2010
    Thanks, I would appreciate that.
  • ninjasinmypantsさんのコメント 12/29, 2010
    This is great stuff. Thanks for working on this!
  • Rastkoさんのコメント 12/30, 2010
    Great Plugin! Thanks a lot!
  • Yoshimasa Niwaさんのコメント 05/08, 2011
    I've got some emails that after updating Reeder for Mac Version 1.0 (Draft 14), this plugin doesn't work. I'll address this sooner, so please wait patiently.

    Reeder for Mac Version 1.0 (Draft 14)にバージョンアップするとこのプラグインが動かないという報告をうけています。追って対応したいと思いますので今しばらくお待ちください。
  • Yoshimasa Niwaさんのコメント 05/11, 2011
    Updated, now it works with Draf 14. Please download the plugin here then replace with old one.

    Draft 14で動くように更新しました。最新のプラグインをダウンロードして既存のものと入れ替えてください。
  • Yoshimasa Niwaさんのコメント 06/13, 2011
    Finally Reeder.app is now on sale at App Store then I make sure that this plugin is also working well with it.

    先日正式版のReederがApp Storeで発売されましたたが、このプラグインも問題なく動作します。
  • senpatsuさんのコメント 06/17, 2011
    素晴らしいプラグインをどうもありがとう
  • Januschさんのコメント 07/23, 2011
    Hello

    after the update today , Reeder 1.1 the Plugin don't work
    You will make a new one?

    Greetz Janusch
  • titiさんのコメント 08/01, 2011
    Thanks a lot for the update!
  • Andysanさんのコメント 08/26, 2011
    Is there a Way or do you plan to make that Plugin work with Reeder/Growl under Lion?
  • Yoshimasa Niwaさんのコメント 08/26, 2011
    Andysan: It should work under Lion.
  • rinmonさんのコメント 08/28, 2011
    アプリとか関係がないが、早くGoogle AppsがGoogle Readerに対応してくれないかな。
  • Andysanさんのコメント 09/03, 2011
    Quote"Error
    Reeder 1.1.2 (v1010.29.00) has not been tested with the plugin GrowlReeder 0.1.2 (v1). As a precaution, it has not been loaded. Please contact the plugin developer for further information."

    No it won't anymore, since i installed the Lion Update…… and it makes me sad……

  • Johnさんのコメント 09/10, 2011
    Be good to have this working once again. Any plans?
  • Yoshimasa Niwaさんのコメント 09/14, 2011
    Andysan: please download latest version of GrowlReeder from this page.
    John: The latest one should work with current Reeder v1.1.2.
  • Andysanさんのコメント 09/16, 2011
    Yes, cool stuff…… best wishes to Japan from Germany, great Job Dude, thanks a lot ^^
  • Jean-Christopheさんのコメント 11/08, 2011
    Thank you very much Yoashima, it works very well now.
  • Philippeさんのコメント 11/15, 2011
    Would you know if this plugin is still working with growl from the Mac app store.
    Thanks.
  • Yoshimasa Niwaさんのコメント 11/15, 2011
    It works, use latest version of this plugin, please.
  • Aveさんのコメント 02/15, 2012
    ありがとう。
  • Oumarさんのコメント 02/18, 2012
    Do you plan to add support for the 1.1.5 version ?

    Kind regards
    Oumar
  • Yoshimasa Niwaさんのコメント 02/19, 2012
    Latest version, plugin 0.1.6 should work with Reeder 1.1.5. If it doesn't work please let me know.
  • Oumarさんのコメント 02/19, 2012
    Hi,
    Thanks for your quick reply. I've installed and SIMBL and the GrowlReeder.bundle file into the User Home/Library/Application Support/SIMBL/Plugins directory. When I open the Growl setting panel, I don't see Reeder in the application list.
    I use the Growl version 1.3.3 and GrowlReeder version 0.1.6
  • pawelさんのコメント 05/21, 2013
    plugin does'n work
お名前
メールアドレス
(任意)
ウェブサイト
(任意)
コメント